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|7 Xinc documentation

Teletext

Overview

The Xinc teletext system allows an Ubuntu Linux based PC to edit teletext pages and insert
them into a video signal.

The software in included in the Debian pacakge xinc-citifax and is copyright HBP/Xinc. This
version requires Ubuntu 8.04 (Hardy Heron) or later.

About teletext

Teletext is digital information embedded in the TV signal. A TV signal consists of 50 fields per
second, each field consists of 312 lines of which 288 holds the picture; 16 of the remaining
lines can hold teletext data. Each line holds one 'row' of teletext data; rows are numbered 0 to
31 and may appear in (almost) any order.

Row 0 indicates the start of a new page, rows 1 to 24 are the 24 lines of text in a teletext
page. Row 27 holds information about the functions of the red, green, yellow and blue buttons
on the remotecontrol.

Very simple mosaic graphics can be included in the teletext pages. The entire page consists of
78x69 pixels.

Teletext supports many languages, including English, German, French, Swedish, Spanish,
Italian, Turkish and Romanian. The languages are not fully supported: for each language up to
13 characters differ from the english set of characters. TV sets in some countries replace some
of the languages with other languages.

Concepts
Here is a brief list of some of the concepts used by the teletext editor:

rastext refers to the coloured links at the bottom line of the page. Hidden information in the
page tells the TV which page numbers these links refer to. The links are accessed using the
red/green/yellow/blue buttons on the remote control.

A text rield is @ an area of a the page which can hold text.

The page titie refers to the middle 24 characters of the top line of the page. It is usually used
to hold the title of the TV channel, or date information.

control characters are used for changing colours, switching between text and graphics mode,
selecting double height text and so on. Each control characters uses 1 character on the screen
and is displayed as a blank.

The scheduier is the program which communicates with the teletext inserter hardware.

There can be 800 pages (100..899) and each page can have up to 79 sub pages, numbered
01..79. The sub pages can be used to create simple slideshows. A sub page is usually specified
as eg. 120-03 (page 120, subpage 03).

The editor

The teletext editor citirditor is available from the Ubuntu menu, in the Graphics submenu and
is also available as an icon on the desktop background.
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The editor performs all editing in UTF-8, allowing characters from all languages to be entered.
The conversion from UTF-8 to the teletext character set is done immediately before the page is
transmitted to the teletext inserter.

Create, load and save page

You can create a new page by selecting the New item from the File menu. Or you can open an
existing page by selecting the Open item, which will display a list of the available pages.
Double clicking on one of the pages will open that page:
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List of pages

The window also provides facilities for copying, renaming and deleting pages. There are a few

things to notice which manipulating sub pages:

® Sub pages are specified as eg. 120-03 (page 120, sub page 03)
® You cannot renumber a page which has sub pages

® Deleting a page also deletes all sub pages for that page
® You cannot renumber a page to become a sub page of a non-existing page
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The Show/Hide button toggles the selected page between being hidden or not. Hidden pages
are marked with a red border and are not sent to the inserter.

Simple editing

If the page doesn't contain any fields then you can simply click anywhere in the page and type
in some text. A window is provided which displays all the available text characters for the
language being used by the page. The window is available from the Tools menu or from the
toolbar.

Clicking on a character in the window will insert it at the position of the cursor (the blinking
white rectangle).
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All characters

Teletext allows the characters from A to Z and a few others (the middle two rows of the
window) to be mixed with mosaic graphics. When editing a graphics field you can click on one
of the characters and then click in the graphics field to insert the character.

You can copy part of the page to an internal buffer, by dragging with the mouse whilst holding
the Ctrl key pressed. The selected rectangular area will be copy to a buffer and may then be
pasted into another page (or elsewhere on the same page) by positioning the cursor
somewhere on the page, and then use the Paste selected area menu, This only works if the
'destination' area doesn't include any fields, and doesn't extend outside the physical page.

Another window provides access to the control characters. This window is also available from
the Tools menu or from the toolbar. To insert a control character first click on its icon in the
window, then click in the page when you want to insert the character.
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All control characters

It is beyond the scope of this documentation to described the use and purpose of the control
characters.

Fields

Two types of text fields are available: normal text and double height text. Double height text
fields can only hold a single line of text and are intended for headlines.

To create a text field, select a field type from the Field / Add menu, then click and drag a box
somewhere in the page. You cannot create a new field that overlaps an existing fields, so you
must start dragging the box outside all fields. When you've dragged a box to specify the
size/position of the new field the field properties window will appear:
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Field properties

The window allows you to specify the title of the field. For double height fields you may also
specify the alignment of the text.

Notice that the control characters needed to switch to graphics mode are not inserted
automatically when you create a graphics field. You should therefore afterwards add the control
characters manually to the left of the field. The same applies to the double height fields - you
should insert a double-height control character to the left of the top line of the double height
field. Remember to take this into account before you create the field.

The field properties window also appears if you double click in an existing field.

Fields can be deleted from the Field menu. When deleting a field the text in the area previously
occupied by the field is left untouched. The menu also allows you to clear the contents of a
field, and to copy the contents of a text field, which may then be pasted into another text field.

Editing the contents of a field

To edit the contents of a text field, simply click in the field and type. The rest of the page will
be 'greyed out' to indicate the part of the page occupied by the field.

To edit the graphics in a graphics field, simply click and draw with the mouse. To clear pixels,
hold the Shift key pressed while you draw.

Language

The language of the page can be changed by selecting another language from the Tools /
Language menu.

The language doesn't affect the contents of the page. It is simply an attribute of the page and
tells the TV which font to use to display the characters in the page, but it may affect which
characters are available in the font.

The editor will attempt to use diacritics to generate the characters, but whether this works
depends on the TVs. Some characters cannot be generated using diacritics, for example the

character E which is only available when using German language. In any other language it will
be displayed as ﬁ

Page title

Double clicking in the middle of the top line of the page will open the page title window where
you can edit the title of the page.

|= Page title =
Page title [XINC TTV %4 %d %b % |

The following is replaced in the taxt
W s replaced by
Woa is raplaced by the abibreiaved wadkday nams
Wl is replaced by the abibredaced wedbkday name Hirsc lemer s upparcased
Wb i3 replaced by the abbreviated mesth name
RE Is replaced by the abbresdated mantch name frsc lemer s sppercase)
%d 13 replaced by the day 11,310
WO is replaced by the dayiol. 21}
%m i3 replaced by the manth (1121
%M ix replaced by the month (01, 131
%y e replaced by the year 108,548
% i replaced by the year leg, 20080

Apply to all pages for this client x Cancel & oK

Editing the page title

The title may include codes for inserting the current date/month/year; a list of the supported
codes is included in the window. Notice that some of the codes expand to 3 or 4 characters -
the total length of the expanded title is limited to 24 characters, any more than that will be cut
off. Also notice that f.ex. the name of the weekday is 2 characters in some languages and 3 in

31/10/2010 10:48



Xinc information system file:///C:/Website2008-v6_website/CitiEditor.html

50f6

other.

Since you will often want to have the same title for all pages, the window includes a button to
do just that. You will be asked to confirm that you really want to do this.

The page title window is also available from the Tools menu.

Fastext

The bottom line of the screen is reserved for links to other pages. Double clicking on the line
will open the Fastext window where you can enter the text and page number for each of the 4
coloured buttons on the remote control. Usually the remote control will also have an index
button - the page for this button can also be set.

Instead of typing the page number you can simply click on the coloured button on the page
thumbnail at the top. This will open the page list window, where you can simply double click on
the page you want to link to.
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Editing Fastext links

The links can have a coloured background. The control characters needed to set the colours are
added automatically by the editor. Notice however that the control characters for the colour
background takes up an additional 7 characters of the 40 characters on the line (besides the 4
characters used for setting the text colours), leaving just 29 characters for the actual text.

The Fastext window is also available from the Tools menu.

Limitation of teletext pages

These are some of the limitation imposed by teletext.

If a line includes double height text then the line below cannot hold any text or graphics.

Mosaic graphics is selected by inserting a 'select graphics colour' character on a line. Switch
back to text by inserting a 'select text colour' character. The characters A to Z and @ and a few
others are allowed amongst the graphics.

You need 3 control characters to display text on a coloured background: first select a
foreground (text) colour, then set the background colour from the foreground colour and finally
set a new foreground colour.

Some TV sets do not support black text - avoid using black text when designing pages.
Inserter

The teletext inserter is a piece of hardware which connects to the PC. A small program (the
'scheduler') on the PC continuously reads the pages created by the editor and sends them to
the inserter.

License keys

Some of the features of the software are controlled by 'license keys'. Each license key is a line
in the file /etc/xinc-1icense.key. Currently two license keys are required: a key named
"TTEDITOR' to allow the editor to save pages, and a key named 'TELETEXT' to enable the
software (the 'scheduler') to control the inserter hardware.

Translating the editor
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All texts in all menus and windows in the editor may be translated by editing the file /usr/10cal

/share/xinc/translation/teletext.txt. ThiS should only be attempted by experienced users! The
characters are in UTF-8.

If a new version of the software includes texts that wasn't included in the previous version
then those texts will not automatically be merged into the file containing the translations.
Instead you should open the file /usr/share/doc/xinc-citifax/default-translation.txt and COpy
the missing texts from that file.
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